2/08/2017

no override found for 'vtkPolyDataMapper'


When meet this error no override found for 'vtkPolyDataMapper' using VTK.
Add this code

#include "vtkAutoInit.h" 
VTK_MODULE_INIT(vtkRenderingOpenGL2); // VTK was built with vtkRenderingOpenGL2
VTK_MODULE_INIT(vtkInteractionStyle);
Or
#define vtkRenderingCore_AUTOINIT 2(vtkRenderingOpenGL2, vtkInteractionStyle)

More detail
refer to this url
http://stackoverflow.com/questions/18642155/no-override-found-for-vtkpolydatamapper